Problems with new B205D monitor

  1. #1 by Albert Burton on 1 Week Ago
    Albert Burton's Avatar
    Posts: 5

    Problems with new B205D monitor

    Hi.

    I have had my B205D monitor for less than 3 months and it has had only very slight use, maybe 4 occasions, in that time. It has thrown up a problem overnight in that the Main input on the rear does not respond to an input signal, (that's not mistakenly using the Thru output). A signal put in there at line level from a mixer or another B205D's Thru output has a ridiculously low effect and is almost inaudible, very much lower than when it was previously working, though it appears to be clear and undistorted.

    A microphone put in the same socket can be heard with the Master Volume up absolutely full but it is also at a very reduced and unusable level. The Mic/Line switch on the rear has no effect on either of these inputs.

    The other inputs on the front work as they should with sensible levels and they respond to both the Master Volume and their own Volume controls as they should. All cables and inputs are XLR balanced. I have changed sources and cables to no effect. The cables also meter out correctly and the microphone works directly into a mixer.

    I really only want to confirm that there is not something obvious I am missing, or if this is a known issue with the B205D which has a simpler fix than returning it under warranty.

    Many thanks.
  2. #2 by Albert Burton on 1 Week Ago
    Albert Burton's Avatar
    Posts: 5
    Just for the sake of completeness and in case there are other halfwits out there...

    Duurrrrhhhh! Problem solved and it was just another 'lunatics in charge of the asylum' type.

    It helps if the guy feeding you the signal from the 'Thru' socket of his B205D is aware that the Mic/Line switch on the back is for the output not the input! It's clearly marked that way but who looks at that before they go head first into using the monitor?

    Trying it out at home with the XLR output of my Marshall had it working instantly. Once the other B205D was switched to 'Line' it also came up as normal. (In fairness to Frank, he isn't totally culpable. It would have helped if I had known too.)

    So for anyone out there finding this because of a similar problem, check that switch first. Be aware that the 'Mic/Line' switch is for the level of signals put OUT via the 'Thru' male socket, not IN via the 'Main' female socket.
  3. #3 by David Plunkett on 6 Days Ago
    David Plunkett's Avatar
    Posts: 46
    We use 205's in our band, and often encounter the problem you described. With us it's usually because the switch gets accidentally set the to wrong position for the pass through to work properly - happens when they are packed away and bump up against something.

    So, you're not alone!
  4. #4 by Albert Burton on 4 Days Ago
    Albert Burton's Avatar
    Posts: 5
    Haha! Glad to hear it David. It should be said, we are a bunch of pretty old guys, The '60s/'70s were my playground and the rest of the guys from the same to the '80s. It does make you wonder how much of this problem is caused by the fun we got up to in the '60s making itself known now!

    (Wibble wibble, throw another poodle on the fire Professor Fortesque, the Archbishop is about to divest himself.)

    I have to say that it almost seems counter intuitive that the switch should act on the output rather than the input but once you spot it it is very practical.
  5. #5 by David Plunkett on 2 Days Ago
    David Plunkett's Avatar
    Posts: 46
    We're not spring chickens either. Our bass player is 75, our main vocalist is a youthful 34 and the rest of us are in our 60s.