New firmware updates - Mic Mechanic 2 and Duplicator

  1. #1 by Spencer Larsen on 07-11-2018
    Spencer Larsen's Avatar
    Posts: 527

    New firmware updates - Mic Mechanic 2 and Duplicator

    Hey, folks!
    This is just a heads up that we've released new firmware on VoiceSupport today - updates for Mic Mechanic 2 and Duplicator, as well as new presets for Duplicator. Please update your respective pedal and enjoy the new features offered Details below...


    Mic Mechanic 2 Build 20:
    Adds a new mode which links the footswitch to the Delay effect only!
    If you hold the Tone button while powering on the pedal, it will boot into a new mode where the Reverb effect is unaffected by the footswitch. This means you can have Reverb constantly active while toggling Delay on and off with the footswitch! This setting is remembered across power cycles. To return footswitch control to both the Delay and Reverb effects again, just repeat the process of holding Tone while powering on.

    Tap Tempo timeout timer removed.
    If you hold the footswitch down for two seconds while the pedal is on, you can tap-in the Delay’s tempo. This Tap Tempo feature now no longer times out, so the pedal will continue to blink at the Delay’s tempo until you hold the footswitch again for another two seconds.


    Duplicator Build 19:
    Increases the maximum level of the doubling voices!
    This update introduces new “factory” presets which increase the maximum level of the doubling voices to be on par with your input voice.

    Fixes some internal issues, satisfying our developers’ OCD.

    Duplicator presets:
    Tom has graciously completed new preset voicings! In addition to the new factory presets, there are three packs of three presets - two of the packs are new presets, and the third pack is the original factory presets which this new build overwrites (in case users are accustomed to the original sound and want to revert). The new presets isolate octave doublings (just an octave below, or just an octave above, as opposed to both) and can even mute the lead voice effectively shifting the user’s voice an octave in either direction.

    Spencer Larsen
    Engineer, Testing
    TC Helicon,
    MUSIC Tribe
    Our Support Team is always available for more urgent assistance.
  2. #2 by Ryan Tomko on 4 Weeks Ago
    Ryan Tomko's Avatar
    Posts: 2

    Preset Issue

    I applied build 19 successfully and wanted to try out the Octave Down/Up presets and ran into two issues that i was hoping you could help with:

    1) The pure octave up and octave down (#1 in each of those two packs) doesn't seem to mute the normal input as stated. It sounds like there is no difference between #1 and #2 in those packs - that is to say both sound like lead + up or lead + down instead of up only or down only. Am i crazy or is that as intended?

    2) After trying out the octave up and down packs i wanted to get the new build 19 (louder) preset however in the Cloud there is only the Original Factory Presets which, if i understand, build 19 replaces. I did another firmware update (even though i was already at build 19) assuming it would install the new louder factory presets and after the update my Duplicator presets were still the Octave up and down i had just previously loaded. So it seems the firmware update does not overwrite the existing presets?? Can you make the new (louder) build 19 presets available in the Cloud so that i can send them to the device?
  3. #3 by John Gruber on 3 Weeks Ago
    John Gruber's Avatar
    Posts: 2

    Cannot update Firmware in VoicePlay

    Trying to update Firmware. Will not connect to PC running Windows 10. . I have followed instructions from Help. Still not able to connect. Any help would be appreciated.
    Thanks
  4. #4 by Spencer Larsen on 1 Week Ago
    Spencer Larsen's Avatar
    Posts: 527
    Ryan,
    Thanks for pointing this out. I think we've identified the issue and fixed VoiceSupport so you can now get the new presets. Basically the new presets were in the Cloud, but VoiceSupport wasn't downloading them properly, it was grabbing older presets with the lead still audible. I believe this disconnect has been fixed so if you try in VoiceSupport again the Cloud presets there should be the new one, please let me know if it still isn't working for you, but it should be fixed now. Sorry for the mixup, our bad!

    John,
    Unfortunately there isn't one answer here, could be a number of issues. Firstly, I recommend using a USB port on the rear of your PC (provided you aren't on a laptop) as they are more stable. Use a known-good USB cable, as some USB-micro cables out there are for power transfer only. Once connected, you should see the Duplicator appear in your Device Manager. If you're not seeing it there, perhaps we can pursue this further in a new thread.

    Spencer Larsen
    Engineer, Testing
    TC Helicon,
    MUSIC Tribe
    Our Support Team is always available for more urgent assistance.