How do I route X18 FX to PC DAW ?

  1. #1 by Dave Beard on 12-13-2017
    Dave Beard's Avatar
    Posts: 6

    How do I route X18 FX to PC DAW ?

    Hi, another newbie question I suspect.

    I've tried searching this forum, looking at the video tutorials, and the X AIR for PC wiki pages... no luck.

    I have on a channel (#4) the Hall Reverb set up as an Insert. The reverb sounds just fine on my Main outs, and in my headphones, but when I record channel 4 in my DAW... Reaper... it is a dry signal.

    I am a bit puzzled by the two boxes below the effect's Insert toggle box, I cannot find any explanation for them, but the top one I have selected "Ch 04", and the bottom one is "OFF".

    The last sentence of the wiki for the FX tab states "See the Effects Overview chapter for more details. " but I can't find any Effects Overview chapter.

    Any help is appreciated!
    -Dave
  2. #2 by Rex Beckett on 12-13-2017
    Rex Beckett's Avatar
    Posts: 577
    - Dave Beard wrote View Post
    I have on a channel (#4) the Hall Reverb set up as an Insert. The reverb sounds just fine on my Main outs, and in my headphones, but when I record channel 4 in my DAW... Reaper... it is a dry signal.
    It sounds as though you have the tap-point for your USB output set to Analog or Input which are both before the insert point. Set the tap to Pre EQ to record the signal after the inserted FX.

    I am a bit puzzled by the two boxes below the effect's Insert toggle box, I cannot find any explanation for them, but the top one I have selected "Ch 04", and the bottom one is "OFF".
    The two boxes allow you to insert each side of a stereo or dual FX processor into two different channels.

    The last sentence of the wiki for the FX tab states "See the Effects Overview chapter for more details. " but I can't find any Effects Overview chapter.
    See The Manual or The Wiki

    Last edited by Rex Beckett; 12-13-2017 at 09:34 AM.
  3. #3 by Dave Beard on 12-13-2017
    Dave Beard's Avatar
    Posts: 6
    Thanks Rex,
    It sounds as though you have the tap-point for your USB output set to Analog or Input which are both before the insert point. Set the tap to Pre EQ to record the signal after the inserted FX.
    When you say "tap-point" I am taking this to mean "Insert Point".
    On my "Sends" tab, the four FX sends are Post Fader. I tried Pre-EQ as you suggested, and it made no difference.

    Also, I have now spent some hours reviewing the Wiki, and the Manual, without success. I suspect both are out of date, however, I don't think that affects my issue.
    Example: I could not find any documentation for the "In/Out" window accessed via the Setup and Routing section.
  4. #4 by Ken Mitchell on 12-13-2017
    Ken Mitchell's Avatar
    Posts: 1,460
    - Dave Beard wrote View Post
    Thanks Rex,


    When you say "tap-point" I am taking this to mean "Insert Point".
    On my "Sends" tab, the four FX sends are Post Fader. I tried Pre-EQ as you suggested, and it made no difference.

    Also, I have now spent some hours reviewing the Wiki, and the Manual, without success. I suspect both are out of date, however, I don't think that affects my issue.
    Example: I could not find any documentation for the "In/Out" window accessed via the Setup and Routing section.
    Hi Dave,

    By tap-point he means the point at which the USB send is "tapped" out of the signal path. To set these you go to In/Out, USB Sends, and right click on the little circle on the matrix for the channel(s) fo want to change.

    The tap points are identified here: http://behringerwiki.music-group.com...Block_Diagrams

    Ken
  5. #5 by Craig Fowler on 12-13-2017
    Craig Fowler's Avatar
    Posts: 2,075


    By default the ch>USB sends are set at the "Analogue" tap point, ie before any channel processing, including inserted FX. To change this, you need to go into the In/Out>USB sends tab, select the relevant channel in the routing matrix, and change its tap point from "Analogue" to something after the insert point ("Pre-eq" would be the first option) by right-clicking.
  6. #6 by Dave Beard on 12-14-2017
    Dave Beard's Avatar
    Posts: 6
    Thanks Ken and Craig, now I get it... and also I realize what I was doing using reverb as an insert was incorrect, as that way, as an insert, I get 100% reverb "wet", not a blend of dry and wet verb. Well, I guess I could if the reverb had a wet/dry blend, but it doesn't.

    So I need to figure out a way to take a blended signal and route it to Reaper.

    Btw, on the USB Sends matrix, there is both an "FX" source, and an "Effect" source. What is the difference between the two?
  7. #7 by Dan Bekkers on 12-14-2017
    Dan Bekkers's Avatar
    Posts: 156
    - Craig Fowler wrote View Post


    By default the ch>USB sends are set at the "Analogue" tap point, ie before any channel processing, including inserted FX. To change this, you need to go into the In/Out>USB sends tab, select the relevant channel in the routing matrix, and change its tap point from "Analogue" to something after the insert point ("Pre-eq" would be the first option) by right-clicking.
    I believe you'll have to go to the routing tables for USB and assign the actual Effect bus to a USB channel for capture. Of course, this will be the sum of the effect and not the effect per channel. I apply this routing methodology to have effects sent to the P16M I'm using... The P16M is not USB, but similar principles.

    Last edited by Dan Bekkers; 12-14-2017 at 08:32 AM.
  8. #8 by Rex Beckett on 12-14-2017
    Rex Beckett's Avatar
    Posts: 577
    - Dave Beard wrote View Post
    So I need to figure out a way to take a blended signal and route it to Reaper.
    One way is to use a bus for this mix. Route your channel (post fader) to the bus but not to main LR. Also send the channel post-fader to one of the FX sends. Raise the FX return fader for the bus (but not main LR) and you've got your effected mix. You can now route the bus to main LR - the bus's main fader will allow you to control the amount in the mix. You can also select the bus for your USB send (pre-fader is probably best).

    Last edited by Rex Beckett; 12-14-2017 at 08:50 AM.
  9. #9 by Dave Beard on 12-15-2017
    Dave Beard's Avatar
    Posts: 6
    Thanks Rex.
    I don't see how to route my channel post fader to a bus or FX send. The only thing I can see is to highlight my channel, and click on the Bus 1-6 to the right of the Mixer window, and raise the slider. Ditto FX.

    There is in the "In/Out" window under the "USB Sends" tab where I can select what Channel, FX, Bus, Effect (still can't figure out what that does) and Main get sent to what USB Send to my DAW.

    I did figure out a way to do what I wanted:

    On the In/Out Input tab, I route my channel Analog input (#4 in this case) to Channel 4 and 16. Then I use a Reverb insert on channel 4, nothing on channel 16. Then I raise the #4 and #16 Bus faders after I highlight Bus 1 for balancing the wet/dry (4 and 16 resp.) mix. Then on the In/Out USB Sends tab, I route Bus 1 to USB 4.

    Thus, I hear via the monitor output the wet/dry mix for input 4, and it also gets sent over USB 4 to my DAW. But I lose a channel(#16).

    I would love to learn how to do what you're saying, but can't see how to do it within all the selections I can get to in the X AIR PC editor!

    -Dave
  10. #10 by Craig Fowler on 12-15-2017
    Craig Fowler's Avatar
    Posts: 2,075
    I don't see how to route my channel post fader to a bus or FX send. The only thing I can see is to highlight my channel, and click on the Bus 1-6 to the right of the Mixer window, and raise the slider. Ditto FX.
    Select the channel, click on the "Sends" tab at the top of the screen. You'll get tap points and level control for that channel going to each bus bus.