Harmony Singer 2 Issues [Resolved]

  1. #51 by Ryan Tomko on 05-26-2018
    Ryan Tomko's Avatar
    Posts: 2

    Firmware Update Failed - Fixed!

    Just wanted to thank Craig and Spencer for posting how to correct a failed firmware update. I thought i could add the missing bits that I had to discover.

    During the update to build 12 i suspect my front usb port on my tower failed (i have intermittent connection for my phone with that port as well) which caused the same "brick" behaviour in that when i turned on the HS2 i got a green light and that's it - no other lights and the buttons did not work and no audio output at all.

    I googled for Bome SendSX and was able to install it easily.

    Fix was to:
    - Connect the device to a more stable (back) usb port
    - Close all programs in windows
    - Start the device in boot mode by holding down the footswitch and tone while powering up, let windows recognize it
    - Start Bome and select the HS2 under Midi Out
    - Set the Actual Midi Speed to 3125 bytes/second under Options->Settings, to speed up the transfer from default but still a safe slow value i think
    - Send the secret code via Bome "F0 00 01 38 00 60 7E 7E 00 00 00 00 00 00 00 00 F7"
    - Send the build 12 file that had VoiceSupport2 had already downloaded, this was the step i didn't understand but after some searching i found the file in my AppData folder:
    C:\Users\<username>\AppData\Roaming\TC-Helicon\VoiceSupport 2\Harmony Singer 2\firmware\Harmony Singer 2 1.0.04 Build12.syx. If AppData is not visible you'll need to tell Windows to show hidden folders in the Control Panel.
    - Wait for device to stop blinking and it reboots on its own, after reboot the tone and footswitch lights came on so i knew it probably worked
    - Power off and disconnect usb
    - Power on and enjoy harmonies all day!

    Thanks again, was sad for a bit when i thought i had just bricked the device less than an hour after unboxing, and would have to return. Your posts really saved me!
  2. #52 by David Ayala on 07-13-2018
    David Ayala's Avatar
    Posts: 1

    Boot mode

    - Spencer Larsen wrote View Post
    Hey Craig,
    Sorry to hear your pedal died... My guess is that the connection was lost at a crucial point in the update process and the pedal goofed. I would have thought VoiceSupport is able to handle this scenario, but anyways let's try to bring it back to life. So yes you're almost there, put it in boot mode, hook it up via USB, the step you're missing is that you need to send it a kind of "Get ready to accept firmware" message prior to actually sending the firmware.
    Use Bome to send the pedal "F0 00 01 38 00 60 7E 7E 00 00 00 00 00 00 00 00 F7" and then you can send it the firmware syx. If the transfer fails partway through, Bome is sending MIDI too fast for the pedal to keep up with, and you'll need to throttle your send speed (mine is set to 989 bytes/second just to play it safe). Hopefully that works for you
    Hi Spencer, I have the same issue as Craig. But I don't know what is syx and Bome. Can you help me please? I really need this pedal and I don't want to give up with it. Do I need a different software or something?

    Thanks