PDA

View Full Version : X - toutch compact midi help



Dani Nasaudean
05-31-2017, 09:50 PM
Hy...i'm new in midi...can anyone tell me how to configure my x toutxh..so I can use it live..with my band...?is there a midi tutorial..??please..Ihave an xr18..and I cant program the compact controller via the editor..I just dont know..please help me....IRead here some of the posts..so people prigramed thouse two..but I cant program..and..if you can tell me..how to hook up..everything...because I tryed in many ways..but maybe you can give me the best posibble way..
Thanks..in advance
Dany

Kevin Maxwell
06-01-2017, 05:30 AM
Hy...i'm new in midi...can anyone tell me how to configure my x toutxh..so I can use it live..with my band...?is there a midi tutorial..??please..Ihave an xr18..and I cant program the compact controller via the editor..I just dont know..please help me....IRead here some of the posts..so people prigramed thouse two..but I cant program..and..if you can tell me..how to hook up..everything...because I tryed in many ways..but maybe you can give me the best posibble way..
Thanks..in advance
Dany

I can probably help you but I am on my way out to do some work for a sound company. Do you have the X-Touch Compact edit program on a windows PC? http://www.music-group.com/licencePopup?mediaCode=P0B3L_MGMEDIA_Editor%20for% 20Windows%20V1.21&url=//downloads.music-group.com/software/behringer/X-TOUCH/X-TOUCH-EDITORv1-21.zip
Are you hooking this up to program with a USB cable between the computer and the XTC?

I will have to get into this more later but I will copy and paste below some info. My experience is using an XTC with an M32 as a fader wing but to the best of my knowledge the midi is the same on the XR18.

>>>>>>>>>>>>>>>>>>>>>
I got to play a bit with the XTC (X-Touch Compact) hooked up to the M32. As it comes from the factory it doesnít play too nice with the M32. I did a factory reset to be sure. The main issue is the global channel needs to not be on 1 or 2. I turned it to off and that seems to work fine. If you set it to one you get a midi loop that drives the M32 and XTC crazy. If you set it to 2 then as you bring up a fader about halfway up the mute comes on. Because the mute function is on channel 2.

The behavior of the XTC and the M32 works fine if you have it connected to each other using Midi cables hooked up to the ins and outs. But if you hook up a computer to the XTC with the USB cable also to set things up in the X-Touch editor it messes up the communication. The XTC receives Midi from the M32 and reacts to it, but even though the Midi out light is lighting on the XTC it doesnít seem to be sending anything to the M32. As soon as I unplug the USB cable from the computer it goes back to working. The one thing I just noticed that is different is when there is no USB cable hooked up to the computer both the Midi in and out lights light up. But with the USB cable hooked up to the computer only the out light or the in light will light up depending on which device you are manipulating the fader on. This having to keep unplugging the Midi cable as you are trying to setup the XTC in the editor and test to see if it is working the way you want is annoying.

All of the preset CC# for the faders are off by 1. Channel one should start with CC0 not CC1. So as it comes from the factory fader 1 on the XTC controls fader 2 on the M32. And so on down the line. That is because 1 is actually 0.

The X32 Midi implementation document for Music Group is in decimal like the edit software but when documenting things a while ago, for my sake, I was reading everything in Hex. I donít know if I could have asked Midi-OX to output decimal instead but when Palladium was working only with Midi it used Hex so I got used to looking at it that way to write the X32 Palladium mixer file.

I also discovered another weirdness while writing this. I was trying to set the buttons 34-39 as the mute group buttons and they donít behave that same way as the channel mutes do when setting the channel mutes on buttons 1-8. To get the light to sync between the Mute Groups and the XTC I had to set the minimum and maximum values on buttons 34-39 opposite of how I set 1-8. But now it works. And looking at my documentation for the Mute Groups (for some reason) 0 is on and 127 is off. It is wrong in the Midi implementation document that I have. BTW the Midi document seems to have disappeared from the Music Groups web site. I recently emailed a copy of what I have to someone on the forum that was looking for it.

<<<<<<<<<<<<<<<<<<<

Dani Nasaudean
06-03-2017, 11:34 PM
I send the product back to the dealer..but..If i will find the info..and i will be sure that he will work..I will buy it back..cand you send the mail to me too..??daniel.nasaudean@yahoo.com it;s my email..so..please sent it to me too..or here..
thanks, in advance..
ps: is there a toturial fot the midi implementation..somewere..??