PDA

View Full Version : B215D awful noise, inconsistent.



Matt Graunke
06-06-2013, 05:20 AM
I have a B215D that when plugged in and in use, at inconsistent times, it will begin just squealling / humming / popping. When this happens, I can turn the Vol / Gain down all the way, and it continues, just as if it was full 100%. I can remove the input cable, and it continues. It stops of course, when I remove the power.

When I fire it back up, it is normal. But it will happen again at some point. I can't figure out what is causing it, or where to look for a fault. Has anyone else experienced this event?

Ben Obee
06-14-2013, 08:33 AM
I have a B215D that when plugged in and in use, at inconsistent times, it will begin just squealling / humming / popping. When this happens, I can turn the Vol / Gain down all the way, and it continues, just as if it was full 100%. I can remove the input cable, and it continues. It stops of course, when I remove the power.

When I fire it back up, it is normal. But it will happen again at some point. I can't figure out what is causing it, or where to look for a fault. Has anyone else experienced this event?

I haven't heard this particular issue happening so I believe that it's a pretty rare one. In this case the only remedy here would be to get the unit serviced by our CARE department if it's still covered under warranty.

You can contact them at CARE@music-group.com.

If you're out of the warranty contact an authorized service center near you:

http://www.behringer.com/EN/Support/Service-Information.aspx

Kind Regards,